We have identified the root cause of the access issues affecting users in the south-central United States. The issue is due to a Cloudflare incident which appears to be impacting connectivity for users in Arkansas, Missouri, Louisiana, Tennessee, Oklahoma, Mississippi, and parts of Texas.
During this incident window, customers can continue to access Bloomerang by connecting through a VPN service. This will route your connection outside the affected region and restore normal access.
We are working with Cloudflare to understand the issue and we will provide updates as we receive more information.
Posted Apr 17, 2026 - 11:39 EDT
Identified
We have identified the cause of the login issues is related to DNS connectivity problems with internet service providers around the Texas, Arkansas, and Oklahoma region. Our team will provide an update as more information becomes available.
Posted Apr 17, 2026 - 10:53 EDT
Investigating
We’re currently experiencing degraded performance issues with one or more of our listed components. Some customers are reporting issues logging into Bloomerang. Our team is currently working to restore operations to full performance. We apologize for any inconvenience.
Posted Apr 17, 2026 - 09:56 EDT
This incident affects: Bloomerang CRM (CRM App - crm.bloomerang.co).