Intermittent performance issues

Incident Report for Bloomerang

Resolved

This issue is resolved.
Posted Dec 23, 2025 - 14:36 EST

Monitoring

A fix has been implemented and we are monitoring results.
Posted Dec 23, 2025 - 13:41 EST

Investigating

We’re currently experiencing degraded performance issues with one or more of our listed components. Some customers may see slower loading times while navigating their database. Our team is actively working to resolve this issue.
Posted Dec 23, 2025 - 12:50 EST
This incident affected: Bloomerang CRM (CRM App - crm.bloomerang.co).