Partial Outage in Constituent Search

Incident Report for Bloomerang

Resolved

This issue is resolved.
Posted Jul 28, 2025 - 13:40 EDT

Identified

Some customers may experience difficulty finding constituents using the search bar. Our team is currently working to restore normal performance levels. We apologize for any inconvenience and will post another update once this is resolved.
Posted Jul 28, 2025 - 10:31 EDT
This incident affected: Bloomerang CRM (CRM Search).