Partial service outage preventing users from logging in

Incident Report for Bloomerang

Resolved

This incident has been resolved, all systems are fully operational.
Posted Mar 06, 2023 - 16:15 EST

Monitoring

We are seeing service restored and users should now be able to log in without issue. We will continue to monitor to ensure normal performance levels are restored.
Posted Mar 06, 2023 - 15:52 EST

Investigating

We’re currently experiencing degraded performance issues causing some users to be unable to log in to Bloomerang. Our team is currently working to restore normal performance levels. We apologize for any inconvenience. Users may be affected. An update will be provided in 30 minutes.
Posted Mar 06, 2023 - 15:41 EST
This incident affected: Bloomerang CRM (CRM App - crm.bloomerang.co).