Following close monitoring, we can now confirm that Bloomerang Volunteer has remained stable and is functioning as expected. The earlier connectivity issues have been fully resolved.
Thank you for your patience while we monitored the situation. If you experience any further issues, please don’t hesitate to contact us at support@bloomerang.com
Posted Jul 10, 2025 - 17:55 EDT
Monitoring
We are currently monitoring our systems following intermittent connectivity errors affecting Bloomerang Volunteer. From approximately 3:10 PM to 3:40 PM ET, some users may have encountered 404 errors while attempting to access the platform.
At this time, the system appears stable. We will continue to monitor closely and post updates here as we confirm that services are fully restored.
If you continue to experience unexpected 404 errors, please contact us at support@bloomerang.com
Posted Jul 10, 2025 - 16:05 EDT
This incident affected: Bloomerang Volunteer (Volunteer App - volunteer.bloomerang.co).