ACH donation errors for Stripe Express (Legacy Bloomerang Payments) for Kindful Fundraising Tools

Incident Report for Bloomerang

Resolved

This issue has been resolved.
Posted Sep 09, 2026 - 21:21 EDT

Monitoring

A fix has been implemented and we are monitoring results.
Posted Sep 09, 2026 - 20:54 EDT

Identified

The issue has been identified and is specific to Kindful Fundraising Donation pages. Our team is actively working on a fix to restore ACH as a payment method for affected customers.
Posted Sep 09, 2026 - 17:48 EDT

Investigating

We are aware that some donors may be experiencing errors when attempting to complete donations using ACH bank transfer on various donation and giving forms. This issue is isolated to our customers utilizing Legacy Bloomerang Payments (Stripe Express). Other payment methods are not affected. Our team is actively investigating and working to restore service as quickly as possible.
Posted Sep 09, 2026 - 17:16 EDT
This incident affected: Bloomerang CRM (CRM - Payments).